Latest news

Loading...

Tuesday, August 21, 2012

Troubleshooting WiFi can be tricky...

Don't you hate it when your interwebs goes down? It's been happening to me a lot lately where I would lose all connectivity, yet my cable modem and router both say everything's fine, and I've been racking my brain trying to figure out the source of the problem.

Like many, my first reaction was to call tech support. When I called, I asked if there was an outage in the area, since it seemed as though I was connected to my router but not pulling any web sites, I assumed it was an outage. Having worked tech support for a living, I'm sure my ISP's support was going to love my call.

When I called about a week ago, the tech said he saw a "lot of packet loss" on my cable modem, and there wasn't an outage, so I had the option of having a tech come out or visiting the office and having my modem replaced. My wife was on the cordless phone so I couldn't ask her what time she'd be home to send a tech out, so I chose the latter. 

But after I hung up, I got to thinking more about what might be the lowest common denominator to the problem, and it did occur to me that it was raining when these outages occurred, so I went outside to where the box was connected from the main line to the house and noticed a lot of growth from an untrimmed forsythia bush around the box (along with a spider or three), so, at 10PM at night, after a monsoon, I grab the trimmers and decide to prune the forsythia away from the outside box. My wife had hung up the phone and came out holding the flashlight wondering what the hell I was doing...

Once I completed the pruning, my internet connectivity was back. So I was happy that I might have fixed the problem. But I noticed the issue return last weekend. It had rained briefly but not a lot to make me think there was the same problem as last time.

One of my kids was on the phone and asked if we were having internet problems because her friend was having the same issues. So, I chalked it up to an actual outage and tried again an hour later, and it was fine.

So earlier tonight, it happens yet again. No internet. I was at my ropes end this time. I called tech support on my cell phone (I couldn't use the home phone because my wife was talking to a friend about a rash on Lauren's head) and had to wait 5 minutes for a tech. I ran outside to check the box (it hasn't rained since last Friday) and all was fine. I went downstairs and rebooted the modem and my WiFi router twice. Then, as my wife hung up the phone and asked me what was going on, the tech came on the line and miraculously my internet came back up.

We spent a few minutes with tech support discussing my options, and once again I decide I probably need to swap out the cable modem, so I get off the phone with tech support, then it hits me...the home phone!!!

Now I start to replay all the outages and sure enough, the HOME PHONE was in use every single time. I have bundling through my cable provider for TV, internet, and phone service. My initial instinct was that one service was screwing up another.

I hop back on the phone with tech support and tell them about my discovery. But the tech support guy had one up on me that I hadn't considered, yet should have thought about first. He simply asked "do you have a CORDLESS phone?"...

And that's when it struck me, my 2.4GHz cordless phone was interfering with the 2.4GHz WiFi router I just acquired 3 weeks ago.

It appears that they're on the same channel and when I get a phone call, the cordless phone is transmitting a more powerful signal between the base and handset and simply kills my WiFi.

So I was foiled by my own cordless phone. And I'm left with a decision. Get a different phone, set my WiFi router to a specific channel that may not be covered by the cordless phone, or perhaps ditch the home phone entirely, which we've thought about doing anyway.

But I'm still trying to figure out the "packet loss" from the first call. Lazy tech near the end of his shift perhaps? Or was there was some legitimate issues with the outside box and the forsythias?

To be continued?

EDIT: Changing the wireless channel on the WiFi seems to have done the trick.

Saturday, August 11, 2012

Curiosity "UFO" ID'ed?

The very first picture from Curiosity on the Martian surface turned the internet upside-down because of an object that looked like an odd formation of some sort. However, the image was just a thumbnail, or a smaller sized image of the original to give viewers a glimpse of the original image, and the resolution was not very good due to the thumbnail's small size. 

Because time was critical due to the pass of Mars Odyssey overhead relaying the telemetry and data before it went out of range of the rover, the smaller thumbnails were programmed to be relayed back to Earth, and only 2 thumbnail-sized images were transmitted before Mars Odyssey went beyond Curiosity's new Martian horizon.

Kaboom!
However, later in the day when more images were sent from the rover's Hazcam, the formation disappeared. Almost instantly the internet was abuzz with hypothetical ideas as to what the phenomenon was, from dust cover debris to UFO's.

The leading theory, however, may be even cooler than E.T.

It is suspected that the object was a dust cloud caused by the crash-landing of the rover's "sky-crane" stage moments after dropping Curiosity onto the ground, and intentionally flying away to prevent it from colliding with the rover. It is believed that, as Curiosity was getting used to its new home and was snapping pictures through its Hazcams, it caught the sky crane slamming into the ground some 2000 feet away!

Once the higher-resolution image was downloaded to Earth, the image resembled more of a mushroom cloud and the direction of the camera coincided with where the sky-crane crashed according to images sent back from the orbiting Mars Reconnaissance Orbiter.

Now the big question is, will Curiosity take a detour to the site to see what the dust cloud might have uncovered?

Thursday, August 9, 2012

Incredible videos from Curiosity's descent

NASA
All eyes are on Mars this week as Curiosity made it's landing in one of the most complex maneuvers ever attempted on the red planet.

As curiosity descended it took video of its landing via the Mars Descent Imager, or MARDI. The video is grainy as the rover is currently sending thumbnail images (the high-res images will come in eventually, albeit slowly since they are so large and so many) to give a sample of what happened on it's way to the surface.

The concave black strips around the border are the result of the fish-eye lens that the camera was using to record the video. Fish-eye lenses allow a much larger field of view to be recorded. The view was inverted to flatten the background and present the video in a format more recognizable to viewers.


Along with the "good bye to the heat shield" video, MARDI also captured the landing. It's abbreviated, but NASA assures us a better video is on its way from the rover as soon as it can be sent.


Now that the high-gain antenna has been aligned with earth, we should be getting a lot more amazing pictures and videos in the upcoming days. I can't wait!